[spesmilo/electrum] WidgetException: Cannot add , it already has a parent (#4624)

Crash Report
============

This crash report was reported through the automatic crash reporting system 🤖

Traceback
—————

«`Python traceback
File «/data/data/org.electrum.electrum/files/app/crystax_python/site-packages/kivy/core/window/window_sdl2.py», line 727, in mainloop
self._mainloop()
File «/data/data/org.electrum.electrum/files/app/crystax_python/site-packages/kivy/core/window/window_sdl2.py», line 460, in _mainloop
EventLoop.idle()
File «/data/data/org.electrum.electrum/files/app/crystax_python/site-packages/kivy/base.py», line 340, in idle
self.dispatch_input()
File «/data/data/org.electrum.electrum/files/app/crystax_python/site-packages/kivy/base.py», line 325, in dispatch_input
post_dispatch_input(*pop(0))
File «/data/data/org.electrum.electrum/files/app/crystax_python/site-packages/kivy/base.py», line 291, in post_dispatch_input
wid.dispatch(‘on_touch_up’, me)
File «kivy/_event.pyx», line 707, in kivy._event.EventDispatcher.dispatch
File «/data/data/org.electrum.electrum/files/app/crystax_python/site-packages/kivy/uix/behaviors/button.py», line 179, in on_touch_up
self.dispatch(‘on_release’)
File «kivy/_event.pyx», line 703, in kivy._event.EventDispatcher.dispatch
File «kivy/_event.pyx», line 1214, in kivy._event.EventObservers.dispatch
File «kivy/_event.pyx», line 1098, in kivy._event.EventObservers._dispatch
File «/data/data/org.electrum.electrum/files/app/crystax_python/site-packages/kivy/lang/builder.py», line 64, in custom_callback
exec(__kvlang__.co_value, idmap)
File ««, line 39, in
File «./gui/kivy/uix/dialogs/wallets.py», line 64, in open_wallet
app.load_wallet_by_name(self.ids.wallet_selector.selection[0])
File «./gui/kivy/main_window.py», line 520, in load_wallet_by_name
launch_wizard()
File «./gui/kivy/main_window.py», line 518, in launch_wizard
wizard.run(action)
File «./lib/base_wizard.py», line 79, in run
f(*args)
File «./lib/base_wizard.py», line 112, in upgrade_storage
self.waiting_dialog(partial(self.storage.upgrade), _(‘Upgrading wallet format…’), on_finished=on_finished)
File «./gui/kivy/uix/dialogs/installwizard.py», line 965, in waiting_dialog
pos=Window.center, width=’200sp’, arrow_pos=None, modal=True)
File «./gui/kivy/main_window.py», line 836, in show_info_bubble
info_bubble.show(pos, duration, width, modal=modal, exit=exit)
File «./gui/kivy/uix/dialogs/__init__.py», line 144, in show
m.add_widget(self)
File «/data/data/org.electrum.electrum/files/app/crystax_python/site-packages/kivy/uix/layout.py», line 97, in add_widget
return super(Layout, self).add_widget(widget, index, canvas)
File «/data/data/org.electrum.electrum/files/app/crystax_python/site-packages/kivy/uix/widget.py», line 531, in add_widget
% (widget, parent))

WidgetException: Cannot add , it already has a parent
«`

Reporter
————

This issue was reported by 1 user(s):

| Electrum Version | Python Version | Operating System | Wallet Type | Locale |
|—|—|—|—|—|
| 3.2.1 | | Android 4.4.2 on samsung picassowifi (KOT49H.T520XXUANI1) | standard | ? |

Additional Information
————————

The reporting user(s) did not provide additional information.

Добавить комментарий