[spesmilo/electrum] Failed to launch Electrum 3.2.2, ImportError: No module named ‘typing’ (#4642)

Hello,
I just tried to update Electrum to version 3.2.2 on a Ubuntu cold wallet.
When I launched it, the wallet failed to open and the following error trace was shown on the console:

`Traceback (most recent call last):
File «electrum», line 70, in
imp.load_module(‘electrum’, *imp.find_module(‘lib’))
File «/usr/lib/python3.4/imp.py», line 245, in load_module
return load_package(name, filename)
File «/usr/lib/python3.4/imp.py», line 217, in load_package
return methods.load()
File ««, line 1220, in load
File ««, line 1200, in _load_unlocked
File ««, line 1129, in _exec
File ««, line 1448, in exec_module
File ««, line 321, in _call_with_frames_removed
File «/home/jack/Scaricati/Electrum-3.2.2/lib/__init__.py», line 3, in
from .wallet import Synchronizer, Wallet
File «/home/jack/Scaricati/Electrum-3.2.2/lib/wallet.py», line 52, in
from .bitcoin import *
File «/home/jack/Scaricati/Electrum-3.2.2/lib/bitcoin.py», line 33, in
from . import ecc
File «/home/jack/Scaricati/Electrum-3.2.2/lib/ecc.py», line 29, in
from typing import Union
ImportError: No module named ‘typing’`

In case any library is missing, I need someway to install it offline, as the wallet is on a airgapped computer.
Any help would be highly appreciated.

Добавить комментарий