[ripple/rippled] Support for boost 1.68 (#2652)

miguelportilla commented on this pull request.

> set(_boost_COMPILER «-vc141;-vc140»)
— elseif (NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 19)
— set(_boost_COMPILER «-vc140»)
— elseif(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 18)
— set(_boost_COMPILER «-vc120»)
— elseif(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 17)
— set(_boost_COMPILER «-vc110»)
— elseif(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 16)
— set(_boost_COMPILER «-vc100»)
— elseif(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 15)
— set(_boost_COMPILER «-vc90»)
— elseif(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 14)
— set(_boost_COMPILER «-vc80»)
+ elseif(MSVC_TOOLSET_VERSION GREATER_EQUAL 80)
+ set(_boost_COMPILER «-vc${MSVC_TOOLSET_VERSION}»)

I doubt a version below 18 (vc120) will compile the project. We may want to remove the attempt to set anything less than vc140 in the future.

Добавить комментарий