[ripple/rippled] Modernize CMake Build (#2579)

JoeLoser commented on this pull request.

>
-setup_build_boilerplate()
+cmake_minimum_required (VERSION 3.7.0)
+set (CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/Builds/CMake ${CMAKE_MODULE_PATH})
+include (CMakeFuncs)
+if (target)
+ message (WARNING
+ «The target option is deprecated and will be removed in a future release»)

Can you share the deprecation rollout plan? Or is it just TBD future release after this lands in master?

Добавить комментарий