[ripple/rippled] Modernize CMake Build (#2579)

JoeLoser commented on this pull request.

> + src/ripple/protocol/digest.h
+ src/ripple/protocol/tokens.h
+ DESTINATION include/ripple/protocol)
+install (
+ FILES
+ src/ripple/protocol/impl/STVar.h
+ src/ripple/protocol/impl/secp256k1.h
+ DESTINATION include/ripple/protocol/impl)
+
+#[===================================================================[
+ rippled executable
+#]===================================================================]
+
+#[=========================================================[
+ this one header is added as source just to keep older
+ versions of cmake happy. cmake 3.10+ allows

There are several nice features that came in 3.10 and 3.11 family. Any particular reason why 3.7 was chosen as the min version to support?

This post was last modified on June 14, 2018, 6:31 am