[EOSIO/eos] [Darwin] Could not find a configuration file for package «libbson-static-1.0» (#4080)

I experienced the same issue. Looks like the recent stable version of https://github.com/mongodb/mongo-cxx-driver.git needs 1.10.0 whereas v3.2 only needs 1.9.3, what we have.
So to fix, we change the references to https://github.com/mongodb/mongo-cxx-driver.git from recent/stable to recent/v3.2. i.e. change line 319 in eosio_build_darwin.sh to
`if ! git clone https://github.com/mongodb/mongo-cxx-driver.git —branch releases/v3.2 —depth 1`

Добавить комментарий