[bitcoin/bitcoin] zmq: update to avoid deprecated zeromq api functions and log zmq version used (#13596)

In that case, please update [dependencies.md](https://github.com/bitcoin/bitcoin/blob/master/doc/dependencies.md) with what would be the new minimum required version.

I’d also suggest combining these changes into #13578, so that the zmq bump, testing, and any minimum version requirement discussion can happen together.

Добавить комментарий