[bitcoin/bitcoin] ZMQ: Small cleanups in the ZMQ code (#13686)

What do you think about wrapping the code with `zmq` namespace and removing `ZMQ/zmq` prefix from class/function names?
Basically when the location of the file is `a/b/c.cpp` then we have:
«`c++
namespace a {
namespace b {
class C {}
}
}
«`