[bitcoin/bitcoin] Obtuse error if Xcode components need to be updated (#13601)

Gah! Spent a while troubleshooting before I found this thread.

Following @Sjors’ suggestion, I had already run `xcode-select —install` — but tried again and was prompted for a new install! **I had just updated to High Sierra (10.13.6), so I had to re-run it (to accept ToS, and install).** This fixed the build problem; simply `make clean`, `./autogen.sh`, `./configure`, `make`.