[bitcoin/bitcoin] Boost or whatever compilation error (#13973)

I tried to build from depends, and the same… or I am doing something really wrong:

cd depends
make
cd ..
./autogen.sh
./configure —prefix=`pwd`/depends/x86_64-linux-gnu —with-incompatible-bdb
make