Сryptocurrency development analysis

# What was the problem?
When upgrading from 1.0.0-rc.2 to 1.0.0-rc.3, the version in config.json stayed as 1.0.0-rc.2. Looks like minVersion is affected as well
### How did I fix it?
Made a slight modification to update_config.js so that version and minVersion are always taken from the new config
### How to test it?
When running 1.0.0-rc.2, upgrade to 1.0.0-rc.3:
— bash installLisk.sh upgrade -r test
### Review checklist

* The PR solves #2338

You can view, comment on, or merge this pull request online at:

https://github.com/LiskHQ/lisk/pull/2339

— Commit Summary —

* Unconditionally keep version/minVersion from new config file when

— File Changes —

M scripts/update_config.js (8)

— Patch Links —

https://github.com/LiskHQ/lisk/pull/2339.patch
https://github.com/LiskHQ/lisk/pull/2339.diff